Degraded performance on DeepL Pro API

Incident Report for DeepL

Postmortem

We recently implemented a change to our system that initially performed well in development and test environments. However, when we deployed it into production, we encountered unexpected issues that affected system performance. We quickly reverted our change and as a result only a small fraction of API calls to our api-us.deepl.com endpoint failed. Before we make the change again, we will investigate the problem and get a clear understanding of what happened.

Posted Apr 24, 2025 - 14:08 UTC

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 13:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 13:54 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 13:42 UTC

Investigating

We are investigating this issue.

Affected Services: Translations
Additional Info: Elevated error rate for api-us.deepl.com
Posted Apr 24, 2025 - 13:35 UTC
This incident affected: DeepL Pro API.