Degraded performance on DeepL Pro

Incident Report for DeepL

Postmortem

An issue with the Outlook Addin went unnoticed for several days due to a failure in our alerting system. We discovered the issue on the 22nd of April at 18:52 UTC and resolved it within a few minutes, this incident affected the use of the Outlook Addin for all users who didn't cache the addin files. The root cause was a failure in our alerting system which did not trigger notifications for the anomalous behaviour. To prevent future occurrences, we are improving our monitoring and alerting systems by reviewing the alerting of the affected service and improving the overall monitoring of the affected service.

Posted Apr 22, 2025 - 19:16 UTC

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 19:00 UTC

Investigating

Affected Services: Outlook Addin/Plugin
Posted Apr 18, 2025 - 07:00 UTC
This incident affected: DeepL Pro.