MFA Login Unavailable

Incident Report for DeepL

Postmortem

From Friday, March 21 at 09:04 UTC until Monday, March 24 at 16:42 UTC, multi-factor authentication (MFA) logins were unavailable for some users, preventing access to DeepL services. The issue has since been resolved, and MFA login is functioning normally.

We are implementing improvements to avoid similar disruptions in the future and apologize for any inconvenience this may have caused.

Posted Mar 24, 2025 - 17:01 UTC

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 16:43 UTC

Investigating

We are currently investigating this issue.
Posted Mar 24, 2025 - 16:10 UTC
This incident affected: DeepL Pro, DeepL Free, DeepL Pro API, and DeepL Free API.