Partial outage on DeepL Free
Incident Report for
DeepL
Resolved
This incident has been resolved.
Posted
Sep
12
,
2023
-
09:54
UTC
Investigating
We are investigating this issue.
Affected Services:
Translations
Posted
Sep
12
,
2023
-
08:26
UTC
This incident affected: DeepL Free.
×
Subscribe to Incident
Subscribe to updates for
Partial outage on DeepL Free
via . You'll receive .