High latency on DeepL Pro API in US datacenter

Incident Report for DeepL

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 09:24 UTC

Monitoring

We've rolled out a fix and will continue monitoring latencies.

Customers using the new v3 glossary endpoints (edited or multi-language glossaries) will see errors as a side effect of this fix. Translation with monolingual (v2) glossaries will work as expected. We are working to restore behaviour for glossaries with v3 features. For customers that need translation with v3 glossaries, can use api.deepl.com/v2/translate (with a higher latency since it is served by a datacenter outside the US).
Posted Apr 29, 2025 - 09:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2025 - 09:01 UTC

Investigating

We are investigating high latency for customers using the DeepL Pro API in our US datacenter.
Posted Apr 29, 2025 - 08:54 UTC
This incident affected: DeepL Pro API.