Degraded performance on DeepL Pro
Incident Report for
DeepL
Resolved
This incident has been resolved.
Posted
Apr
29
,
2025
-
13:00
UTC
Investigating
We are investigating this issue.
Affected Services:
Document Translations
Additional Info:
We are investigating errors and timeouts for translating documents
Posted
Apr
29
,
2025
-
12:30
UTC
This incident affected: DeepL Pro.
×
Subscribe to Incident
Subscribe to updates for
Degraded performance on DeepL Pro
via . You'll receive .