Degraded performance on DeepL Pro

Incident Report for DeepL

Postmortem

Between 12:57 and 13:05 UTC, a restart of one of our network components caused intermittent connection issues, resulting in an elevated error rate. We are working on measures to prevent this from happening in the future and apologize for any inconvenience this may have caused.

Posted Mar 24, 2025 - 13:54 UTC

Resolved

Between 12:57 and 13:05 UTC Pro users experienced an elevated error rate.
Posted Mar 24, 2025 - 12:57 UTC