Major outage on DeepL Pro
Incident Report for
DeepL
Resolved
This incident has been resolved.
Posted
Sep
11
,
2023
-
19:32
UTC
Investigating
We are investigating this issue.
Affected Services:
Login (SSO)
Affected Clients:
Website, Windows App, MacOS App, Android App, iOS App
Posted
Sep
11
,
2023
-
16:51
UTC
This incident affected: DeepL Pro.
×
Subscribe to Incident
Subscribe to updates for
Major outage on DeepL Pro
via . You'll receive .