Partial outage on DeepL Voice

Incident Report for DeepL

Postmortem

On Feb 24 at 10:08 UTC, we experienced a 40-minute outage of teams services when a misconfiguration, specifically involving lost connectivity on a VPN between Microsoft and our central datacenter, disrupted our communications used for MS Teams. Our team promptly investigated the issue, identified the root cause—a faulty configuration that caused connectivity issues—and restored service. We apologize for any inconvenience this caused our customers. Moving forward, we are implementing stricter change controls, enhanced monitoring tools, and additional training to help prevent similar incidents and ensure a more resilient network.

Posted Feb 24, 2025 - 11:10 UTC

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 10:51 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2025 - 10:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2025 - 10:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2025 - 10:47 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2025 - 10:46 UTC

Update

We are continuing to investigate this issue.
Posted Feb 24, 2025 - 10:45 UTC

Investigating

We are investigating this issue.

Affected Services: Voice
Additional Info: We are investigating issues related to DeepL Voice
Posted Feb 24, 2025 - 10:08 UTC
This incident affected: DeepL Pro, DeepL Voice for Meetings, and DeepL Voice for Conversations.