Degraded performance on DeepL Pro
Incident Report for DeepL
Postmortem

An internal authentication system failure has resulted in the Account Usage page being inaccessible. Once we'd identified and removed the faulty systems, the Account Usage page was accessible again. Throughout the incident, only reading data from the Account Usage page was affected. The actual aggregation of usage data was not affected.

Posted Sep 29, 2024 - 06:20 UTC

Resolved
This incident has been resolved.
Posted Sep 29, 2024 - 06:13 UTC
Monitoring
The fix has been applied and the Account Usage page is working again. We are monitoring the situation.
Posted Sep 29, 2024 - 06:02 UTC
Identified
We've identified the problem and are working on a fix.
Posted Sep 29, 2024 - 05:44 UTC
Investigating
We are investigating this issue.

Affected Services: Account Usage
Affected Clients: Website
Additional Info: We are investigating issues with http://deepl.com/your-account/usage and showing the current account usage.
Posted Sep 28, 2024 - 23:44 UTC
This incident affected: DeepL Pro.