Degraded performance on DeepL Pro, DeepL Pro API

Incident Report for DeepL

Resolved

A fix has been implemented.
Posted Mar 05, 2025 - 18:56 UTC

Monitoring

We've identified and isolated a faulty node. The higher latency that some users may experience should now be better. We are monitoring the situation.
Posted Mar 05, 2025 - 18:21 UTC

Investigating

We are investigating this issue.

Affected Services: Translations, Document Translations, Glossary, Write, Login, Login (SSO)
Additional Info: Our automated alerting notified us of degraded response times in a datacenter.
Posted Mar 05, 2025 - 17:50 UTC
This incident affected: DeepL Pro and DeepL Pro API.