Partial outage on DeepL Pro, DeepL Pro API

Incident Report for DeepL

Postmortem

On March 11, from 02:40 UTC to 02:55 UTC, a routing misconfiguration caused an internal outage that affected customers ability to use of glossary features properly. Our network operations team quickly identified the root cause and restored the affected services, successfully bringing everything back online and resuming normal operations. Importantly, translations were not impacted. To prevent similar disruptions in the future and enhance the stability of our network infrastructure, we are implementing additional safeguards. We sincerely apologise for any inconvenience this may have caused during this time.

Posted Mar 12, 2025 - 13:39 UTC

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 15:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 14:59 UTC

Investigating

We are investigating this issue.

Affected Services: Glossary
Affected Clients: Website, Windows App, MacOS App, Android App, iOS App, Chrome Plugin, Edge Plugin
Posted Mar 11, 2025 - 14:52 UTC
This incident affected: DeepL Pro and DeepL Pro API.