Degraded performance on DeepL Free, DeepL Free API
Incident Report for
DeepL
Resolved
This incident has been resolved.
Posted
Feb
25
,
2025
-
10:35
UTC
Update
We are now only seeing degraded performance for German to English translation.
Posted
Feb
25
,
2025
-
10:31
UTC
Investigating
We are investigating this issue.
Affected Services:
Translations, Document Translations
Posted
Feb
25
,
2025
-
09:47
UTC
This incident affected: DeepL Free and DeepL Free API.
×
Subscribe to Incident
Subscribe to updates for
Degraded performance on DeepL Free, DeepL Free API
via . You'll receive .