Partial outage on DeepL Pro

Incident Report for DeepL

Postmortem

At 09:45 UTC, an update to one of our services inadvertently disrupted the generation and download of account activity reports. Our team promptly identified and addressed the issue, successfully restoring full functionality by 11:37 UTC. We apologize for any inconvenience caused and appreciate your understanding as we continuously work to improve our systems and services.

Posted Feb 27, 2025 - 11:43 UTC

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 11:38 UTC

Identified

We have identified the issue and will restore service shortly.
Posted Feb 27, 2025 - 11:32 UTC

Investigating

We are investigating this issue.

Affected Services: Account Reporting
Additional Info: We are investigating issues with downloading usage reports for team members on DeepL Pro
Posted Feb 27, 2025 - 09:45 UTC
This incident affected: DeepL Pro.