Partial Outage on DeepL Pro

Incident Report for DeepL

Postmortem

During routine maintenance on our database system, an isolated node unexpectedly rejoined the cluster, causing intermittent service interruptions to customers.
We quickly followed established procedures to resolve the issue and successfully restored full functionality.

Later on we noticed that some customers using the API still experienced issues validating their API key. This was also due to data not being replicated properly to all nodes of the database cluster, yet. We addressed the issue by making the API key resolution process more robust in such cases.

Posted Mar 06, 2025 - 18:04 UTC

Resolved

We have rolled out a fix and the issue has been resolved.
Posted Mar 06, 2025 - 17:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 06, 2025 - 17:31 UTC

Identified

We are again seeing a small number of API requests fail, we have identified the problem and are working on a fix.
Posted Mar 06, 2025 - 17:29 UTC

Update

We can confirm that service is restored and error rates have further reduced. We will continue monitoring for errors.
Posted Mar 06, 2025 - 16:17 UTC

Monitoring

We've identified and rolled out a fix. Error rates are reducing are services are being restored. We will continue monitoring.
Posted Mar 06, 2025 - 15:58 UTC

Investigating

We are looking into errors within the authentication layer which are preventing users from using DeepL Pro services.
Posted Mar 06, 2025 - 15:39 UTC
This incident affected: DeepL Pro and DeepL Pro API.