Degraded performance on DeepL Free, DeepL Free API
Incident Report for DeepL
Postmortem

Due to a software malfunction, document translation for free users was significantly slower for many users. We are implementing measures to prevent such malfunctions in the future.

Posted Sep 10, 2024 - 14:28 UTC

Resolved
Affected Services: Document Translations Free
Affected Clients: Website, API, Apps
Posted Sep 10, 2024 - 12:40 UTC